Elastix проблема с исходящими вызовами

FreePBX, TrixBox, AsteriskGUI и др.
Всевозможные надстройки/интерфейсы к Asterisk в виде GUI.
[всё что прямо не относится к Asterisk писать сюда]

Модераторы: Admins, Модераторы

Ответить
gurgen
Сообщения: 3
Зарегистрирован: 10 мар 2011, 09:37

Elastix проблема с исходящими вызовами

Сообщение gurgen » 24 июл 2017, 11:05

Elastix 2.5
шлюзы FXS и FXO.
Когда абонент FXS звонит через порт FXO, а потом кладет трубку не дождавшись ответа, вызов продолжает идти 3 посылки вызова и если абонент поднимет трубку там тишина. Вот какие сообщения приходят после того как положил трубку.
[Kiha*CLI>
[0K[2017-07-21 10:31:34] [1;31mWARNING[0m[2864]: [1;37mchan_sip.c[0m:[1;37m4263[0m [1;37m__sip_autodestruct[0m: Autodestruct on dialog 'ee987b1f-99fa-1200-248e-a8f94b0e7902' with owner SIP/11-00000044 in place (Method: BYE). Rescheduling destruction for 10000 ms

[Kiha*CLI>
[0K[2017-07-21 10:31:40] [1;31mWARNING[0m[2864]: [1;37mchan_sip.c[0m:[1;37m4263[0m [1;37m__sip_autodestruct[0m: Autodestruct on dialog 'ee987b1f-99fa-1200-248e-a8f94b0e7902' with owner SIP/11-00000044 in place (Method: BYE). Rescheduling destruction for 10000 ms

[Kiha*CLI>
[0K[2017-07-21 10:31:46] [1;31mWARNING[0m[2864]: [1;37mchan_sip.c[0m:[1;37m4263[0m [1;37m__sip_autodestruct[0m: Autodestruct on dialog 'ee987b1f-99fa-1200-248e-a8f94b0e7902' with owner SIP/11-00000044 in place (Method: BYE). Rescheduling destruction for 10000 ms
Помогите разобраться почему так работает.

awsswa
Сообщения: 1723
Зарегистрирован: 28 апр 2012, 10:19
Откуда: Russia, Пермь

Сообщение awsswa » 24 июл 2017, 13:20

Не настроен ловля сигнала BUSY на шлюзе

google - поиск - шлюз d-link ловля BUSY
платный суппорт по мере возможностей

gurgen
Сообщения: 3
Зарегистрирован: 10 мар 2011, 09:37

Сообщение gurgen » 25 июл 2017, 07:40

Сигнал BUSY настраивается на интерфейсе FXO, а отбой приходит по SIP от Elastix.
По входящим звонкам и настраивал сигналы и смог настроить, что входящие звонки понимают отбой приходящий со стороны fxo.

gurgen
Сообщения: 3
Зарегистрирован: 10 мар 2011, 09:37

Сообщение gurgen » 31 июл 2017, 08:11

Почитал на иностранных форумах, надо пересобирать ядро, поэтому установил версию Elastix 4.
Проблема ушла.

Ответить