Список форумов Asterisk Forum Asterisk Forum
The Asterisk Open Source PBX - Russian Community
 
 FAQFAQ   ПоискПоиск   ПользователиПользователи   ПравилаПравила   ГруппыГруппы   ИзбранноеИзбранное    LinksСсылки   РегистрацияРегистрация 
 RSSRSS   ПрофильПрофиль   Войти и проверить личные сообщения   ВходВход 

Ну устанавливается Fail2ban

 
Список форумов Asterisk Forum -> Newbies/FAQ Forum    вывод темы на печать
Предыдущая тема :: Следующая тема  
Автор Сообщение
Xandr84



Зарегистрирован:
11.09.2017
Сообщения: 4

Статус: Оффлайн 

СообщениеДобавлено: Пн Ноя 13, 2017 13:00    Заголовок сообщения: Ну устанавливается Fail2ban

Добрый день!
Пробую собрать систему Asterisk 14.7 на Centos7. при установке Fail2ban выходит ошибка. Подскажите в чем может быть проблема.
[root@centos7 ~]# yum install fail2ban
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: dedic.sh
* epel: fedora-mirror01.rbc.ru
* extras: mirror.yandex.ru
* updates: dedic.sh
Resolving Dependencies
--> Running transaction check
---> Package fail2ban.noarch 0:0.9.6-1.el6.1 will be installed
--> Processing Dependency: python(abi) = 2.6 for package: fail2ban-0.9.6-1.el6.1.noarch
--> Processing Dependency: ed for package: fail2ban-0.9.6-1.el6.1.noarch
--> Processing Dependency: gamin-python for package: fail2ban-0.9.6-1.el6.1.noarch
--> Processing Dependency: python-inotify for package: fail2ban-0.9.6-1.el6.1.noarch
--> Running transaction check
---> Package ed.x86_64 0:1.9-4.el7 will be installed
---> Package fail2ban.noarch 0:0.9.6-1.el6.1 will be installed
--> Processing Dependency: python(abi) = 2.6 for package: fail2ban-0.9.6-1.el6.1.noarch
---> Package gamin-python.x86_64 0:0.1.10-16.el7 will be installed
--> Processing Dependency: gamin = 0.1.10-16.el7 for package: gamin-python-0.1.10-16.el7.x86_64
--> Processing Dependency: libgamin-1.so.0()(64bit) for package: gamin-python-0.1.10-16.el7.x86_64
---> Package python-inotify.noarch 0:0.9.4-4.el7 will be installed
--> Running transaction check
---> Package fail2ban.noarch 0:0.9.6-1.el6.1 will be installed
--> Processing Dependency: python(abi) = 2.6 for package: fail2ban-0.9.6-1.el6.1.noarch
---> Package gamin.x86_64 0:0.1.10-16.el7 will be installed
--> Finished Dependency Resolution
Error: Package: fail2ban-0.9.6-1.el6.1.noarch (epel)
Requires: python(abi) = 2.6
Installed: python-2.7.5-58.el7.x86_64 (@anaconda)
python(abi) = 2.7
python(abi) = 2.7
Available: python34-3.4.5-2.el6.i686 (epel)
python(abi) = 3.4
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Вернуться к началу
Посмотреть профиль Отправить личное сообщение
awsswa



Зарегистрирован:
28.04.2012
Сообщения: 1686
Откуда: Russia, Пермь

Статус: Оффлайн 

СообщениеДобавлено: Пн Ноя 13, 2017 14:59    Заголовок сообщения:

epel я вижу что стоит
какие еще левые репозитарии зацеплены кроме родного и epel

0:0.9.6-1.el6.1 - вот слово el6 при системе у вас el7 - не смущает ?

_________________
платный суппорт по мере возможностей
Вернуться к началу
Посмотреть профиль Отправить личное сообщение Skype Name
Xandr84



Зарегистрирован:
11.09.2017
Сообщения: 4

Статус: Оффлайн 

СообщениеДобавлено: Вт Ноя 14, 2017 06:55    Заголовок сообщения:

Спасибо за ответ!

Помогло следующее:
yum clean all && yum makecache && yum install fail2ban
Вернуться к началу
Посмотреть профиль Отправить личное сообщение
Список форумов Asterisk Forum -> Newbies/FAQ Forum Ответить на тему
Страница 1 из 1

Добавить в Избранное

 
Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете голосовать в опросах
You cannot attach files in this forum
You cannot download files in this forum