trixbox + мультифон

FreePBX, TrixBox, AsteriskGUI и др.
Всевозможные надстройки/интерфейсы к Asterisk в виде GUI.
[всё что прямо не относится к Asterisk писать сюда]

Модераторы: Admins, Модераторы

Ответить
theoc
Сообщения: 176
Зарегистрирован: 15 май 2008, 09:37
Откуда: Нижневартовск

trixbox + мультифон

Сообщение theoc » 20 авг 2010, 11:01

В настройках транка:

Код: Выделить всё

Outbound CallerID: 7922XXXXXXX

Код: Выделить всё

PEER Details:

username=7922XXXXXXX
type=friend
secret=YYYYYYYY
qualify=yes
nat=never
insecure=port,invite
host=193.201.229.35
fromuser=7922XXXXXXX
fromdomain=multifon.ru
dtmfmode=inband
context=from-trunk
disallow=all
allow=alaw

Код: Выделить всё

Register string: [email protected]:YYYYYYYY:[email protected]/7922XXXXXXX
USER Context и USER Details оставил пустыми.

В итоге при регистрации получаю

Код: Выделить всё

SIP/2.0 404 Registrar Not Found
Поделитесь рабочим конфигом, пожалуйста.

edo1
Модератор
Сообщения: 394
Зарегистрирован: 23 июл 2005, 12:19

Сообщение edo1 » 20 авг 2010, 12:03

Код: Выделить всё

register => [email protected]:xxxxxx:[email protected]

[multifon]
type=peer
secret=xxxxxx
username=792xxxxxx
fromuser=792xxxxxx
fromdomain=multifon.ru
host=sbc.megafon.ru
dtmfmode=inband
port=5060
allow=alaw
canreinvite=no
videosupport=no
insecure=invite


Added after 4 minutes:

мне кажется всё у Вас правильно с настройками.
а родной клиент работает?

theoc
Сообщения: 176
Зарегистрирован: 15 май 2008, 09:37
Откуда: Нижневартовск

Сообщение theoc » 20 авг 2010, 12:27

Родной клиент я даже не пробовал.
Зато попробовал на другой версии астериска (без trixbox) и регистрация прошла успешно, блин.

Версия на которой регистрация проходит: Asterisk 1.4.23-rc4

Код: Выделить всё

REGISTER 12 headers, 0 lines
Reliably Transmitting (no NAT) to 193.201.229.35:5060:
REGISTER sip:multifon.ru SIP/2.0
Via: SIP/2.0/UDP AA.AA.AA.AA:5060;branch=z9hG4bK386cd860;rport
From&#58; <sip&#58;[email protected]>;tag=as235d9b0b
To&#58; <sip&#58;[email protected]>
Call-ID&#58; [email protected]
CSeq&#58; 102 REGISTER
User-Agent&#58; Asterisk PBX
Max-Forwards&#58; 70
Expires&#58; 120
Contact&#58; <sip&#58;[email protected]>
Event&#58; registration
Content-Length&#58; 0
                                                                                                                                                                                 
                                                                                                                                                                                 
---                                                                                                                                                                              
17&#58;23&#58;37, 0.13, asterisk01*>
<--- SIP read from 193.201.229.35&#58;5060 --->
SIP/2.0 200 OK
Via&#58; SIP/2.0/UDP AA.AA.AA.AA&#58;5060;received=AA.AA.AA.AA;branch=z9hG4bK386cd860;rport=5060
From&#58; <sip&#58;[email protected]>;tag=as235d9b0b
To&#58; <sip&#58;[email protected]>;tag=aprqpm5q6q1-k8i94t30000c6
Call-ID&#58; [email protected]
CSeq&#58; 102 REGISTER
P-Associated-URI&#58;
Contact&#58; <sip&#58;[email protected]>;expires=1791
Service-Route&#58; <sip&#58;[email protected]&#58;5060;transport=udp;lr>
Версия на которой регистрация НЕ проходит: Asterisk 1.6.0.26-FONCORE-r78

Код: Выделить всё

REGISTER 12 headers, 0 lines
Reliably Transmitting &#40;no NAT&#41; to 193.201.229.35&#58;5060&#58;
REGISTER sip&#58;193.201.229.35 SIP/2.0
Via&#58; SIP/2.0/UDP 80.251.48.181&#58;5060;branch=z9hG4bK22a8ab05;rport
Max-Forwards&#58; 70
From&#58; <sip&#58;[email protected]>;tag=as6ccc0a64
To&#58; <sip&#58;[email protected]>
Call-ID&#58; [email protected]
CSeq&#58; 102 REGISTER
User-Agent&#58; Asterisk PBX 1.6.0.26-FONCORE-r78
Expires&#58; 120
Contact&#58; <sip&#58;[email protected]>
Event&#58; registration
Content-Length&#58; 0


---
trixbox1*CLI> 
<--- SIP read from UDP&#58;//193.201.229.35&#58;5060 --->
SIP/2.0 404 Registrar Not Found
Via&#58; SIP/2.0/UDP ZZ.ZZ.ZZ.ZZ&#58;5060;received=ZZ.ZZ.ZZ.ZZ;branch=z9hG4bK22a8ab05;rport=5060
From&#58; <sip&#58;[email protected]>;tag=as6ccc0a64
To&#58; <sip&#58;[email protected]>;tag=aprqngfrt-3192kq00000c6
Call-ID&#58; [email protected]
CSeq&#58; 102 REGISTER
Пробовал убирать Register string и вручную еще добавил в sip_general_custom.conf Эффекта нет.

edo1
Модератор
Сообщения: 394
Зарегистрирован: 23 июл 2005, 12:19

Сообщение edo1 » 20 авг 2010, 12:37

что различается - ip-адрес вместо multifon.ru:

Код: Выделить всё

From&#58; <sip&#58;[email protected]>;tag=as6ccc0a64
To&#58; <sip&#58;[email protected]> 

theoc
Сообщения: 176
Зарегистрирован: 15 май 2008, 09:37
Откуда: Нижневартовск

Сообщение theoc » 20 авг 2010, 15:29

Хмм... Это мне нужно версию астера на триксбоксе менять?

zlat
Сообщения: 665
Зарегистрирован: 31 июл 2009, 18:23

Сообщение zlat » 20 авг 2010, 16:02

если не ошибаюсь, мультифон для сигналки использует tcp, астер1.4 его не поддерживал

theoc
Сообщения: 176
Зарегистрирован: 15 май 2008, 09:37
Откуда: Нижневартовск

Сообщение theoc » 20 авг 2010, 16:28

Уже нет. То есть, теперь поддерживается и UDP

theoc
Сообщения: 176
Зарегистрирован: 15 май 2008, 09:37
Откуда: Нижневартовск

Сообщение theoc » 25 авг 2010, 04:41

SOLVED!

Откатился на ветку 1.4

upd: При переносе конфигов использовался модуль Backup & Restore 2.5.1.7. Все прошло удачно и без шаманств.

edo1
Модератор
Сообщения: 394
Зарегистрирован: 23 июл 2005, 12:19

Сообщение edo1 » 25 авг 2010, 08:23

для справки - у меня мультифон работает с 1.6:

Код: Выделить всё

2e1*CLI> core show version 
Asterisk 1.6.2.6-1 built by buildd @ biber on a i686 running Linux on 2010-04-11 04&#58;03&#58;45 UTC

HuKuTocKa
Сообщения: 60
Зарегистрирован: 02 апр 2007, 11:31

Сообщение HuKuTocKa » 27 авг 2010, 17:58

Аналогично. Работает с 1.6.

theoc
Сообщения: 176
Зарегистрирован: 15 май 2008, 09:37
Откуда: Нижневартовск

Сообщение theoc » 27 авг 2010, 18:54

С астериском работаю давно, а вот с триксбоксом недавно знаком.

Скорее всего нубовский вопрос, а как вы поставили ветку 1.6.2? Из исходников?
Потому как yum ставит только 1.6.0

edo1
Модератор
Сообщения: 394
Зарегистрирован: 23 июл 2005, 12:19

Сообщение edo1 » 05 сен 2010, 12:45

theoc писал(а): а как вы поставили ветку 1.6.2?
вопрос адресовался мне?
у меня debian ;)

theoc
Сообщения: 176
Зарегистрирован: 15 май 2008, 09:37
Откуда: Нижневартовск

Сообщение theoc » 06 сен 2010, 03:57

На дженту у меня тоже 1.6.2 :)
А тут вот решился на Trixbox "из коробки".

esveka
Сообщения: 14
Зарегистрирован: 02 дек 2008, 22:29

Сообщение esveka » 12 сен 2010, 18:06

А с Nat он как живет? Имеется в виду мультифон )

Ответить